Most current web servers with PHP & MySQL installed will be capable of running WHMCS FIREWALL.

WHMCS V5 and Later (all dependencies of WHMCS V5+ will work with WHMCS FIREWALL)
PHP Version 5.2 minimum (Up to PHP 5.5 supported)
Loaders V4.0 or later
Linux is Fully Supported. Some (not all) features of WHMCS Firewall will work on a Windows server but Linux is HIGHLY recommended and our support desk will not assist with Windows related questions, as it is not fully supported.